poseDeformer for maya2008-x64

david | animation,mel script | Monday, May 26th, 2008

My downloads page now has a version of Michael Comet's poseDeformer which I have compiled for maya2008-x64.

I have not done much testing, but it seems to be working ok on vista 64 with maya2008 sp1 64 bit.

Please test it properly yourself before committing to a production that relys on this plugin. If you encounter problems, feel free to comment here.

Download here. (Its near the bottom of the page)

Update: I've discovered you need to install .net framework 3.5 for this to work correctly.

14 Comments »

  1. Dear Djx,
    im using linuX OS,
    is there any chance that you can compile poseDeformer for maya 8.5 on linuX too,
    this would greatly help me,
    please consider,
    stanley.joseph

    Comment by stanlee — July 2, 2008 @ 6:51 pm

  2. stanlee, I don't know how to compile for linux. I'll look into it, but don't hold your breath. If I figure it out I'll email it to you since I wont have any way to test it either.

    Comment by david — July 2, 2008 @ 8:16 pm

  3. Hi
    I'm using linux OS 64 bit (Ubuntu 8.10 64 bit)
    I've tried to compile pose deformer for maya 2008sp1 64 bit.
    The process went with some errors (missing lib or smt.) but I've got plugins (*.so) compiled.
    Since the compilation went with errors, the plugin doesn't work (it's not loading)
    I would be very grateful If you help me with this.
    Regards
    Yuri

    Comment by fusster — March 21, 2009 @ 7:22 am

  4. I dont think I can help much with any linux stuff.
    If someone else can get it working and email it to me, then I will be happy to add it to the rar for others to download.

    Comment by david — March 21, 2009 @ 3:39 pm

  5. That would be grate
    Thanks

    Comment by fusster — March 21, 2009 @ 7:32 pm

  6. By the way. I believe there is no big deference between compiling maya plugins in Linux and Windows (or Mac).
    I just dont have any experience compiling plugins.

    Comment by fusster — March 22, 2009 @ 12:17 am

  7. I've compiled poseDeformer for linux x64 for maya2009sp1a ( I think it could work with 2009 too )

    if you can give me an email address I can send it to you, so you can share it here...

    Comment by eoyilmaz — June 26, 2009 @ 10:57 am

  8. Thanks eoyilmaz, I've added it in the RAR.

    (Nice site you have there, by the way. http://www.ozgurfx.com )

    Comment by david — June 27, 2009 @ 12:15 am

  9. Hello

    I've tried to install the Pose Deformer (for Maya 2008 64) without any success. I keep getting the message, in the script editor, " // Error: Plug-in, "poseDeformer" was compiled against a newer version of the Maya API and is incompatible with the current Maya version. (poseDeformer) // "
    I have also tried to load earlier versions like the 2008 and bin8.5-x64 but that didn't work either. It said "// Error: Unable to dynamically load : C:/Program Files/Autodesk/Maya2008/bin/plug-ins/poseDeformer.mll"
    I have Windows Vista Business, and i installed the net framework 3.5. I have Maya 2008 x64...

    Can you please help we and figure out what's causing the problem?

    Best regards

    Samir

    Comment by Samir — May 22, 2010 @ 2:14 am

  10. Samir: I finally found a machine with 2008 still on it. It was 2008 x64 extension 2 running on vista 64. The poseDeformer and poseReader plugins work correctly. These are the ones in poseDeformer_ALL.rar in the binWindows/bin2008-x64 folder and are dated 25/05/2008 10:35pm (approx). If you are using these files with this version of maya and getting that error then I do not know what can be wrong. All I can think of is that you have more than one version of the plugin installed on your system and maya is seeing the wrong one first.

    Here are some questions that may help you diagnose the problem.
    Where do you have the files installed? What folder? How do you specify your MAYA_PLUG_IN_PATH environment variable? You should be using Maya.env

    If you email me these details I will try to help you sort it out. PoseDeformer is so good that everyone should have it!

    Comment by david — May 23, 2010 @ 12:36 am

  11. Hi all !
    Dear Djx, if you give me your email, I could send you PoseDeformer compiled for Linux Maya 2010 64 bit and Maya 2011 64 bit

    For thouse hwo need this plugin compiled for Linux Maya 2010 64 bit and Maya 2011 64 bit, I can give you the link for downloading. Furthermore, I can explain how to compile it...

    By the way, the PoseReader wont compile in any condition, I don't know why. So I use the phyton version of PoseReader, found somewere in the web

    Comment by fusster — March 4, 2011 @ 3:28 am

  12. Fusster, I'm trying to compile the PoseDeformer for Linux as well (maya 2011). Can you explain how?

    The link would also be helpful.

    Comment by sidmonster — December 7, 2011 @ 7:20 am

  13. // Error: Plug-in, "poseDeformer" was compiled against a newer version of the Maya API and is incompatible with the current Maya version. (poseDeformer)

    I get this error when I try to check the plugin poseDeformer mml

    is there any chance you can help me

    Comment by mstacey2012b — April 22, 2012 @ 11:44 am

  14. Its been a while, but from memory the 2008 version was compiled against 2008 sp1 (or ext1). Is that the version you have? It probably doesn't work with the original 2008.

    Comment by david — April 22, 2012 @ 12:42 pm

RSS feed for comments on this post.

Leave a comment

You must be logged in to post a comment.

Powered by WordPress | Based on a theme by Roy Tanck